9,066

Views

Beginner

Level

4

Comments

Keyboard Shortcuts

by Jon (Updated on 2012-03-30)


Stencyl has a number of hotkey options that can make working with the app quicker and easier. The hotkey commands below are organized by the section/editor they are used in.  Most of these actions are available via buttons or menus as well.

Note: Shortcuts may change over time. Let us know if something's fallen out of date.

Note: Mac users use Command instead of Ctrl and Option instead of Alt.

 

Welcome Center

  • CTRL+SHIFT+N - Create a New Game/Kit (depending on which you select)
  • ENTER - Open the Selected Item (same as double click)

 

Common Shortcuts Usually Accessible

  • ALT+F - Open File Menu
  • ALT+E - Open Edit Menu
  • ALT+H - Open Help Menu
  • CTRL+P - Go to Stencyl API Page on the Wiki
  • CTRL+M - Show / Hide StencylTalk
  • CTRL+L - Show / Hide Help Center
  • ALT+ L/R ARROWS - Toggle Tabs (except when in the Scene Editor)
  • CTRL+R - Reload Document
  • CTRL+N - Create New... (Actor/Background/Font/Scene/Behavior/Sound/Tileset/Pack)
  • CTRL+G - Open Miniature Game Center Window
  • CTRL+ENTER - Preview / Test Game
  • CTRL+SHIFT+ENTER - Test Game in Browser
  • CTRL+S - Save Game
  • ENTER - Open the Selected Item (same as double click)
  • CTRL+SHIFT+F - Open StencylForge
Note:  Right-click a tab, and you'll be able to split the screen in the app. This can help you easily compare two documents side by side.  Also, this can be useful for tasks such as comparing two Behaviors.


Actor / Background / Tileset Editors

  • ARROWS - Select a Single Frame
  • CTRL+A or CTRL+/ - Select All Frames
  • CTRL+\ - Select No Frames
  • SHIFT+ARROWS - Select All Frames From First Selected to Last Selected
  • DELETE - Delete Selected Frame(s)


Scene Designer

  • SPACE - Toggle Select and Pencil Tools
  • BACKSPACE - Delete the Selected Tile / Actor (alt: CTRL+BACKSPACE, SHIFT+BACKSPACE)
  • CTRL+Y - Redo
  • CTRL+Z - Undo
  • CTRL+SHIFT+K - Send Selected Tile / Actor to Back Layer
  • CTRL+K - Send Selected Tile / Actor Back One Layer
  • CTRL+SHIFT+L - Bring Selected Tile / Actor to Front Layer
  • CTRL+L - Bring Selected Tile / Actor Up One Layer
  • CTRL+E - Customize the Behavior of the Selected Actor
  • + KEY - Scroll Up Through List of Layers
  • - KEY - Scroll Down Through List of Layers
Note:  Holding SHIFT while moving or placing a Actor will snap it to the Scene's Grid.  You can toggle to show / hide the grid with a button in the top right corner of the Scene Editor.


Design Mode

  • CTRL+D - Show / Hide Sidebar
  • CTRL+E - Arrange All Blocks
  • CTRL+K - Delete Loose Blocks
  • CTRL+T - Take Screenshot
  • CTRL+Y - Redo
  • CTRL+Z - Undo
  • ALT+DRAG - Duplicate Blocks
  • SHIFT + DRAG - Drag a Single Block Out of a Stack of Blocks
Note:  Right-click a block in the workspace for options to Undo/Redo, View Help, Find In Palette, Copy/Paste, Duplicate/Remove, Activate/Deactivate, and Add to Favorites.


Sound Editor

  • CTRL+C - Choose File
  • CTRL+M - Edit Sound
Disclaimer: All articles are geared towards Stencyl 3.0 and above. Use comments to provide feedback and point out issues with the article (typo, wrong info, etc.). If you're seeking help for your game, please ask a question on the forums. Thanks!

4 Comments

baberuth
Please add a design mode shortcut to put the cursor in the blocks search box.


0 1 year, 4 months ago
ace999
Please, for the love of God, put this tip into the the very first tutorial:

SHIFT DRAG - Drag a Single Block Out of a Stack of Blocks

Not knowing this was literally driving me crazy! Finding this has made my life so much easier!

0 2 years, 1 month ago
srivello
I recommend that Stencyl adopt some common shortcuts in the situations where users assume they'd exist;
* Command X, Cut
* Command C, Copy
* Command V, Paste
* Command Z, Undo
* Command Shift Z, Redo
* Command A, Select All
* Command F, Find

2 2 years, 4 months ago
Xietao
Really useful
0 2 years, 5 months ago

Sign In to Comment